macOS vai perder compatibilidade com extensões antigas

1 min de leitura
Imagem de: macOS vai perder compatibilidade com extensões antigas
Fonte: https://papers.co/desktop/nb43-apple-logo-dark-bw-life-night-black/
Essa não é uma matéria patrocinada. Contudo, o TecMundo pode receber uma comissão das lojas, caso você faça uma compra.
Avatar do autor

A Apple divulgou um documento indicando que algumas extensões do kernel — também chamadas de extensões legacy — não serão compatíveis com a próxima versão do macOS porque não são "tão seguras ou confiáveis quanto as opções modernas".

O fim do suporte foi anunciado em 2019, quando a Maçã informou aos desenvolvedores que o macOS Catalina seria a última versão com compatibilidade às extensões legacy. Desde a estreia da versão 10.15.4 nesta semana e até que a próxima geração do sistema operacional seja lançada, uma notificação de que a extensão não terá compatibilidade com as próximas versões será exibida toda vez que for executada.

Fonte: AppleFonte: AppleFonte:  Apple 

Thomas Reed, diretor da Malwarebytes, declarou que a Apple tem um novo framework de Endpoint Security — estrutura para fornecer maior segurança à rede e aos dispositivos — para as extensões de kernel.

Estamos cientes disso e trabalhando para alterar nossa extensão do kernel desde o fim do ano passado. Planejamos substitui-la pela nova estrutura de Endpoint Security da Apple antes do lançamento do macOS 10.16, quando se supõe que as extensões do kernel não funcionem mais, em parte ou na sua totalidade. (Sabemos apenas que a Apple disse que "não há garantias de funcionar" em "uma futura versão do macOS", mas preferimos não descobrir da maneira mais difícil o que isso realmente significa.)

Então, não há necessidade de pânico. Ainda estamos protegendo você e não haverá brechas. Tudo o que você precisa fazer é garantir que o Malwarebytes para Mac esteja atualizado. Se você fez upgrade para a versão 4.2 e não desabilitou o novo recurso de atualização automática, ele será renovado em segundo plano sem a necessidade de fazer qualquer ação. Para garantir que tenha a versão mais nova, basta abrir o Malwarebytes e escolher "verificar atualizações" no menu.

Detalhes técnicos para desenvolvedores estão disponíveis na página de suporte da Apple, em inglês.

Comentários

Conteúdo disponível somente online
macOS vai perder compatibilidade com extensões antigas