Quando um navegador é atualizado drasticamente, muitas de suas extensões deixam de ser compatíveis com ele. Apesar disso, existem algumas delas que mantêm a compatibilidade, por mais mudanças que sejam feitas. O fato é que até elas receberem uma atualização oficial de seus desenvolvedores oficiais, era impossível instalá-las no novo navegador. Isso mesmo, “era” impossível: não é mais.

Neste artigo o Baixaki ensina você a fazer o Firefox ignorar a suposta incompatibilidade de versões para permitir a instalação de extensões não atualizadas delas. Todavia, fique avisado desde já: alguns complementos realmente se tornam incompatíveis quando o navegador é atualizado. Portanto, por mais que você faça exatamente como ensinado, isso não é garantia de que a extensão realmente funcionará – tudo vai depender da sorte.

Erro ao tentar instalar

Como acabar com os avisos de incompatibilidade

Quando o aplicativo não recebeu a atualização necessária do desenvolvedor, ele continua a indicar “compatível com as versões X, Y e Z” e ao perceber isso, o Firefox barra sua instalação. Porém, alguns deles continuam compatíveis, o problema é que o Firefox não sabe disso – e nem você, na verdade.

Mensagem que aparece quando já estava instalado

Para descobrir quais dos seus complementos favoritos ainda funcionam na nova versão do navegador, proceda da seguinte maneira: digite about:config na barra de endereços e pressione Enter. Então, clique com o botão direito sobre qualquer região da lista que apareceu, mova o mouse para cima de “New” (Novo) e selecione “Boolean” (Booleano).

Booleano

Uma pequena janela surge. Nela, digite extensions.checkCompatibility.4.0b8 (versão Beta do navegador), ou extensions.checkCompatibility.4.0 – use-a somente quando o navegador sair da fase de testes –, e selecione “OK”.

Novo valor

Logo em seguida, escolha a opção “False” e clique em “OK”.

Valor booleano

Pronto, agora você conseguirá instalar complementos incompatíveis com a versão 4.0 do Firefox! Contudo, tome certo cuidado: extensões como o Greasemonkey passam a abrir infinitamente janelas com a página inicial de seu desenvolvedor – isso acontece porque ele, de fato, ainda não é compatível com a versão nova do Firefox.

Em outras palavras, fique atento para “efeitos colaterais” indesejados, de forma a poder agir prontamente para solucionar a questão – afinal, uma vez desinstalada, uma extensão deixa de causar problemas.

Cupons de desconto TecMundo: